import Foundation
let pattern = #"product_default_shipping_cost:\['(.*?)'\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}