import re
regex = re.compile(r"product_default_shipping_cost:\['(.*?)'\]")
test_str = "product_sale_price:['19.99'], product_default_shipping_cost:['1.99'], product_type:['Newegg']"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")