# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[^s]|src="([^"]*)".*)*/$1/;t' <<< "aoidj
aodifjiao
<img src=\"asdf.asdf\" id=\"a1\" />"