import Foundation
let pattern = #"(?:[^s]|src="([^"]*)".*)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
aoidj
aodifjiao
<img src="asdf.asdf" id="a1" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}