re = /(?:[^s]|src="([^"]*)".*)*/
str = 'aoidj
aodifjiao
<img src="asdf.asdf" id="a1" />'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result