$re = '/(?:[^s]|src="([^"]*)".*)*/';
$str = 'aoidj
aodifjiao
<img src="asdf.asdf" id="a1" />';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;