using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^s]|src=""([^""]*)"".*)*";
string substitution = @"$1";
string input = @"aoidj
aodifjiao
<img src=""asdf.asdf"" id=""a1"" />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}