const regex = /(?:[^s]|src="([^"]*)".*)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^s]|src="([^"]*)".*)*', '')
const str = `aoidj
aodifjiao
<img src="asdf.asdf" id="a1" />`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);