use strict;
my $str = 'aoidj
aodifjiao
<img src="asdf.asdf" id="a1" />';
my $regex = qr/(?:[^s]|src="([^"]*)".*)*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";