// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:[^s]|src="([^"]*)".*)*"#).unwrap();
let string = "aoidj
aodifjiao
<img src=\"asdf.asdf\" id=\"a1\" />";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}