import re
regex = re.compile(r"(?:[^s]|src=\"([^\"]*)\".*)*")
test_str = ("aoidj\n"
"aodifjiao \n"
"<img src=\"asdf.asdf\" id=\"a1\" />")
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)