# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9\.]+)\$\^\{\*{1,3}\}\$/\\textbf{$1}/g;t' <<< "0.047$^{***}$"