package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9\.]+)\$\^\{\*{1,3}\}\$`)
var str = `0.047$^{***}$`
var substitution = "\\textbf{$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}