$re = '/([0-9\.]+)\$\^\{\*{1,3}\}\$/';
$str = '0.047$^{***}$';
$subst = "\\textbf{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;