const regex = /([0-9\.]+)\$\^\{\*{1,3}\}\$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9\\.]+)\\$\\^\\{\\*{1,3}\\}\\$', 'g')
const str = `0.047\$^{***}\$`;
const subst = `\\textbf{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);