re = /([0-9\.]+)\$\^\{\*{1,3}\}\$/
str = '0.047$^{***}$'
subst = '\\\\textbf{$1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result