import re
regex = re.compile(r"([0-9\.]+)\$\^\{\*{1,3}\}\$")
test_str = "0.047$^{***}$"
subst = "\\\\textbf{$1}"
result = regex.sub(subst, test_str)
if result:
print(result)