# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img[^>]*?id=(['"])(.+?)\1//g;t' <<< "<section>
<span><img id=\"id1\" src=\"src\" alt=\"alt\"></span>
<span><img id=\"id2\" src=\"src\" alt=\"alt\"></span>
</section>"