$re = '~<img[^>]*?id=([\'"])(.+?)\1~';
$str = '<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;