import re
regex = re.compile(r"<img[^>]*?id=(['\"])(.+?)\1")
test_str = ("<section>\n"
"<span><img id=\"id1\" src=\"src\" alt=\"alt\"></span>\n"
"<span><img id=\"id2\" src=\"src\" alt=\"alt\"></span>\n"
"</section>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)