#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<img[^>]*?id=(['"])(.+?)\1"
Local $sString = "<section>" & @CRLF & _
"<span><img id="id1" src="src" alt="alt"></span>" & @CRLF & _
"<span><img id="id2" src="src" alt="alt"></span>" & @CRLF & _
"</section>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)