using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]*?id=(['""])(.+?)\1";
string substitution = @"";
string input = @"<section>
<span><img id=""id1"" src=""src"" alt=""alt""></span>
<span><img id=""id2"" src=""src"" alt=""alt""></span>
</section>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}