use strict;
my $str = '<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>';
my $regex = qr~<img[^>]*?id=(['"])(.+?)\1~p;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";