re = /<img[^>]*?id=(['"])(.+?)\1/
str = '<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result