const regex = new RegExp('<img[^>]*?id=([\\'"])(.+?)\\1', 'g')
const str = `<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);