import Foundation
let pattern = #"<img[^>]*?id=(['"])(.+?)\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)