using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+\s+(?:(?:\/(?:user|password|node):\S+\s+){3})process\s+call\s+create\s+(?:.*)";
string input = @"wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create ""notepad.exe""
wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create ""notepad.exe""
wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!` process call create ""notepad.exe""
wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create ""notepad.exe""
wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create ""notepad.exe""
wmic.exe /asdpasd asdasd
wmic.exe /user:adfkjdsf process call create hello.exe
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}