import re
regex = re.compile(r"\S+\s+(?:(?:\/(?:user|password|node):\S+\s+){3})process\s+call\s+create\s+(?:.*)", flags=re.MULTILINE)
test_str = ("wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create \"notepad.exe\"\n"
"wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create \"notepad.exe\"\n"
"wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!` process call create \"notepad.exe\"\n"
"wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create \"notepad.exe\"\n"
"wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create \"notepad.exe\"\n\n"
"wmic.exe /asdpasd asdasd\n"
"wmic.exe /user:adfkjdsf process call create hello.exe\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")