import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\s+(?:(?:\\/(?:user|password|node):\\S+\\s+){3})process\\s+call\\s+create\\s+(?:.*)";
final String string = "wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create \"notepad.exe\"\n"
+ "wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create \"notepad.exe\"\n"
+ "wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!` process call create \"notepad.exe\"\n"
+ "wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create \"notepad.exe\"\n"
+ "wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create \"notepad.exe\"\n\n"
+ "wmic.exe /asdpasd asdasd\n"
+ "wmic.exe /user:adfkjdsf process call create hello.exe\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}