const regex = new RegExp('\\S+\\s+(?:(?:\\/(?:user|password|node):\\S+\\s+){3})process\\s+call\\s+create\\s+(?:.*)', 'gm')
const str = `wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!\` process call create "notepad.exe"
wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!\` process call create "notepad.exe"
wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!\` process call create "notepad.exe"
wmic.exe /password:1q2w£1!\` /user:asfsdfd /node:asdf process call create "notepad.exe"
wmic.exe /password:1q2w£1!\` /user:asfsdfd /node:asdf process call create "notepad.exe"
wmic.exe /asdpasd asdasd
wmic.exe /user:adfkjdsf process call create hello.exe
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}