// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+\s+(?:(?:\/(?:user|password|node):\S+\s+){3})process\s+call\s+create\s+(?:.*)").unwrap();
let string = "wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create \"notepad.exe\"
wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create \"notepad.exe\"
wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!` process call create \"notepad.exe\"
wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create \"notepad.exe\"
wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create \"notepad.exe\"
wmic.exe /asdpasd asdasd
wmic.exe /user:adfkjdsf process call create hello.exe
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}