import Foundation
let pattern = #"\S+\s+(?:(?:\/(?:user|password|node):\S+\s+){3})process\s+call\s+create\s+(?:.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create "notepad.exe"
wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!` process call create "notepad.exe"
wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!` process call create "notepad.exe"
wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create "notepad.exe"
wmic.exe /password:1q2w£1!` /user:asfsdfd /node:asdf process call create "notepad.exe"
wmic.exe /asdpasd asdasd
wmic.exe /user:adfkjdsf process call create hello.exe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)