package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+\s+(?:(?:\/(?:user|password|node):\S+\s+){3})process\s+call\s+create\s+(?:.*)`)
var str = `wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!\` process call create "notepad.exe"
wmic.exe /node:asdf /user:asfsdfd /password:1q2w£1!\` process call create "notepad.exe"
wmic.exe /user:asfsdfd /node:asdf /password:1q2w£1!\` process call create "notepad.exe"
wmic.exe /password:1q2w£1!\` /user:asfsdfd /node:asdf process call create "notepad.exe"
wmic.exe /password:1q2w£1!\` /user:asfsdfd /node:asdf process call create "notepad.exe"
wmic.exe /asdpasd asdasd
wmic.exe /user:adfkjdsf process call create hello.exe
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}