using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(expression=[""|'].*?>)(.*?[""|'])";
string input = @"expression=""9a / 3b - 10c"" > foo=""67 + 34"" // The regular expression should only find up until expression=""99 / 32 - 10"" and no further
expression=""x > 10"" foo=""67 + 34"" // Correct find";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}