use strict;
my $str = 'expression="9a / 3b - 10c" > foo="67 + 34" // The regular expression should only find up until expression="99 / 32 - 10" and no further
expression="x > 10" foo="67 + 34" // Correct find';
my $regex = qr/(expression=["|'].*?>)(.*?["|'])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}