re = /(expression=["|'].*?>)(.*?["|'])/m
str = 'expression="9a / 3b - 10c" > foo="67 + 34" // The regular expression should only find up until expression="99 / 32 - 10" and no further
expression="x > 10" foo="67 + 34" // Correct find'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end