const regex = /(expression=["|'].*?>)(.*?["|'])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(expression=["|\'].*?>)(.*?["|\'])', 'gm')
const str = `expression="9a / 3b - 10c" > foo="67 + 34" // The regular expression should only find up until expression="99 / 32 - 10" and no further
expression="x > 10" foo="67 + 34" // Correct find`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}