import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(expression=[\"|'].*?>)(.*?[\"|'])";
final String string = "expression=\"9a / 3b - 10c\" > foo=\"67 + 34\" // The regular expression should only find up until expression=\"99 / 32 - 10\" and no further\n\n"
+ "expression=\"x > 10\" foo=\"67 + 34\" // Correct find";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}