import re
regex = re.compile(r"(expression=[\"|'].*?>)(.*?[\"|'])", flags=re.MULTILINE)
test_str = ("expression=\"9a / 3b - 10c\" > foo=\"67 + 34\" // The regular expression should only find up until expression=\"99 / 32 - 10\" and no further\n\n"
"expression=\"x > 10\" foo=\"67 + 34\" // Correct find")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")