$re = '/(expression=["|\'].*?>)(.*?["|\'])/m';
$str = 'expression="9a / 3b - 10c" > foo="67 + 34" // The regular expression should only find up until expression="99 / 32 - 10" and no further
expression="x > 10" foo="67 + 34" // Correct find';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);