package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(expression=["|'].*?>)(.*?["|'])`)
var str = `expression="9a / 3b - 10c" > foo="67 + 34" // The regular expression should only find up until expression="99 / 32 - 10" and no further
expression="x > 10" foo="67 + 34" // Correct find`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}