#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td.*?class="MID"[^>]*[\s\S]*?<\/td>"
Local $sString = "<td width="33%" align="left" class="MID">" & @CRLF & _
" <a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>" & @CRLF & _
" </td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")