re = /<td.*?class="MID"[^>]*[\s\S]*?<\/td>/
str = '<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end