// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<td.*?class="MID"[^>]*[\s\S]*?<\/td>"#).unwrap();
let string = "<td width=\"33%\" align=\"left\" class=\"MID\">
<a href=\"ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA\">IOWA</a>
</td>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}