package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<td.*?class="MID"[^>]*[\s\S]*?<\/td>`)
var str = `<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}