import Foundation
let pattern = #"<td.*?class="MID"[^>]*[\s\S]*?<\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}