using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td.*?class=""MID""[^>]*[\s\S]*?<\/td>";
string input = @"<td width=""33%"" align=""left"" class=""MID"">
<a href=""ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA"">IOWA</a>
</td>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}