import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td.*?class=\"MID\"[^>]*[\\s\\S]*?<\\/td>";
final String string = "<td width=\"33%\" align=\"left\" class=\"MID\">\n"
+ " <a href=\"ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA\">IOWA</a>\n"
+ " </td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}