import re
regex = re.compile(r"<td.*?class=\"MID\"[^>]*[\s\S]*?<\/td>")
test_str = ("<td width=\"33%\" align=\"left\" class=\"MID\">\n"
" <a href=\"ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA\">IOWA</a>\n"
" </td>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")