#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.\.\/img\/([\w.]+)"
Local $sString = "background:#eeeded url(../img/bg.jpg)" & @CRLF & _
"background:#eeeded url(../img/bg1.jpg)" & @CRLF & _
"background:#eeeded url(../img/bg2.jpg)" & @CRLF & _
"<img src="../img/logo.jpg">" & @CRLF & _
"<img src="../img/logo1.jpg">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")